Willkommen

Logic Net Eye

© 2004, LogicLink, Marcus Müller

Haben Sie sich nicht schon häufiger gefragt, was eigentlich auf den Rechnern innerhalb Ihres Netzwerkes so alles passiert ? Moderne Betriebsysteme stellen immer mehr Funktionen grafisch dar und ihre Arbeitsweise lässt sich nur noch sehr unzureichend über Log-Dateien und die Kommandozeile erfassen.

Was liegt also näher, als sich die Desktops der Rechner innerhalb eines Netzwerkes übersichtlich anzeigen zu lassen ?

Logic Net Eye zeigt Ihnen die Desktops von Rechnern innerhalb Ihres Netzwerks an und kann diese als Video aufzeichnen. Damit verschaffen Sie sich einen detaillierten Einblick in die Arbeitsweise von Benutzern und können so schnell auf Ereignisse reagieren. Einsatzgebiete sind die Überwachung von Servern, Schulungen bei denen Sie die Fortschritte Ihrer Schüler mitverfolgen wollen, Unterstützung bei Anwenderproblemen, Identifikation der benutzen Software, Fehler-Analyse auf Produktivsystemen und natürlich zu guter letzt die pure Neugier.

Das Programm Logic Net Eye ist Freeware und kann unentgeltlich benutzt werden. Die Software ist das Ergebnis eines Forschungsprojektes der Firma LogicLink, Marcus Müller und wurde als Rotwein-Software entwickelt. Diese Software-Gattung hat den Anspruch, dass die Programmierung nicht länger als der Genuss einer guten Flasche Rotwein dauert. Leider bleibt es meist nur bei dem Anspruch und die Umsetzung erfordert nach der Rotwein-Version, die Weiswein-Version, die Spa-Version, usw. Da wir aus tiefster Seele enthusiastische Software-Entwickler und Überzeugungstäter sind, glauben wir, dass Forschungsergebnisse jedermann unentgeltlich zur Verfügung gestellt werden sollten und verteilen diese Software als Freeware. Trotzdem entstehen uns Kosten durch die Bereitstellung der Software auf unseren Servern, Lizenzgebühren für Entwicklungstools und verwendete Komponenten, und natürlich durch die Blumen für unsere vernachlässigten Ehefrauen...

Daher sind wir auf Ihre Unterstützung bei der Umsetzung und Weiterentwicklung unserer Forschungsarbeiten angewiesen und würden uns über jede Spende Ihrerseits freuen.

Weitere Informationen zu den Modalitäten, unter denen wir Ihnen diese Software zur Verfügung stellen, finden Sie auf der Seite Lizenz.

Diese Software ist dem neugierigsten Menschen gewidmet, den ich kenne und der nur das glaubt, was er auch mit eigenen Augen sehen kann: Meiner Tochter ;-).


Versionen

Neuigkeiten

Nichts ist perfekt und dies gilt in jedem Fall für Software. Für alle Neugierigen, die wissen wollen, was sich in den letzten Versionen so alles geändert hat, hier nun die letzen Neuigkeiten zum Logic Net Eye:

Version 0.4.1

  • Automatische Konfiguration der Windows XP Service Pack 2 Firewall.
  • Administrative Admin$-Freigabe ist für die Remote-Installation nicht mehr erforderlich. Ausnahme: Windows NT 4.
  • Bei der Remote-Installation kann jetzt unter Windows XP oder 2003 ein alternativer Benutzername für die Installation verwendet werden.
  • Fehler bei der Remote-Installation auf Windows NT 4 Rechnern beseitigt.
  • Sicherheitsabfrage bei der Deinstallation des Dienstes auf Windows 2003 Servern wird nicht mehr angezeigt.
  • Automatische Benachrichtigung bei neuen Logic Net Eye Versionsständen.
  • Diverse kleinere Fehlerbeseitigungen.

Version 0.4.0

Es geht los, die erste öffentliche Version.


Einführung

Das Ziel unseres Net Eye Projektes ist die technologische Machbarkeit einer massiv parallelen Übertragung von graphischen Daten in Netzwerken zu prüfen. Dazu soll der Desktop von möglichst vielen Rechnern übertragen und aufgezeichnet werden. Darüber hinaus soll der Einfluss auf Performance und die Sicherheit des Clients möglichst gering sein.

Das erstes Ergebnis des Net Eye Konzeptes liegt jetzt in der Form der Logic Net Eye Software vor. Logic Net Eye verwendet eine Client/Server Architektur, um den Desktop zwischen Rechner zu übertragen:

Die Übertragung erfolgt auf der Basis von TCP/IP und daher als Netzwerkprotokoll erforderlich ist. Dies bietet die Möglichkeit, die Übertragung auch über das Internet stattfinden zu lassen. Für den Übertragungsvorgang ist zum einen die Installation der Client-Komponente auf dem zu beobachtenden Rechnern notwendig und zum anderen der Start der Server-Anwendung auf dem Logic Net Eye Server. Die Übertragung erfolgt in folgenden Schritten:

1. Remote-Installation des Clients

Die Installation des Clients erfolgt vom Server aus über die Dienste-Verwaltung von Windows. Daher kann die Remote-Installation auch nur unter Windows NT, Windows 2000, Windows XP Professional und Windows 2003 Server erfolgen, denn Windows 9x und Me unterstützen keine Dienste. Darüber hinaus ist die Remote-Installation von Diensten auf Windows XP Home Clients nicht möglich, da hier bei diesem System alle Netzwerkverbindugen unter dem Gast-Benutzer hergestellt werden. Weiter sind für die Installation Administrator-Rechte auf dem Client erforderlich.

In den Fällen, in denen eine Remote-Installation nicht möglich ist, kann die Client-Software auch manuell auf dem Zielrechner installiert werden.

2. Meldung des Clients am Server

Nach der erfolgreichen Installation des Clients meldet sich dieser beim Server an. Adresse und Port des Servers sind fest an den Client gebunden und können nachträglich nicht geändert werden. Dies sorgt zwar dafür, dass ein Client immer nur mit einem Server kommunizieren kann, verhindert jedoch einen Missbrauch des Clients durch dritte.

Die Kommunikation findet ab diesem Stadium nur noch über TCP/IP statt und kann nur vom Client aus initiiert werden. Der Client wird als Dienst bei jedem Start von Windows automatisch gestartet und versucht sich dann bei dem eingetragenen Server zu melden.

3. Kommando des Servers an den Client

Nach der Meldung eines Clients antwortet der Server mit Kommandos, die eine Datenübertragung vom Client zum Server initiieren. Diese kann z.B. in der Übertragung des aktuellen Desktops bestehen. Ebenso wird die Deinstallation auf ein Kommando des Servers hin ausgeführt.

Weiter bestimmt der Server die zu übertragende Datenmenge. So werden nur so viele Daten angefordert, wie auch zur Darstellung des Client-Desktops benötigt werden. Dies minimiert den Netzwerkverkehr zwischen Client und Server.

4. Datenübertragung vom Client zum Server

Nach der Anforderung von Daten durch den Server bestimmt der Client, welche Bereiche des Desktops sich geändert haben und überträgt diese Daten an den Server. Dieser stellt den Desktop als Miniaturansicht oder Vollbild dar. Parallel kann der übertragene Desktop als Video aufgezeichnet werden.

Die Datenübertragung wurde so konzipiert, dass möglichst wenig Rechnerleistung auf dem Client erforderlich ist. Trotzdem handelt es sich bei einer Desktop-Darstellung einfach um eine große Datenmenge, die transportiert werden muss. Falls es sich bei dem Client um einen älteren PC handelt, sollten Sie daher gegebenenfalls die Farbtiefe der Desktop-Übertragung verringern und das Aktualisierungsintervall möglichst lang wählen.

5. Remote-Deinstallation des Clients

Wenn keine Daten mehr vom Client benötigt werden, kann dieser über ein Remote-Kommando vom Server aus rückstandsfrei deinstalliert werden.

Nach der Deinstallation muss die Client-Software wieder über die Dienste-Verwaltung vom Server aus installiert werden. Daher sollten Sie genau überlegen, ob die Deinstallation wirklich notwendig ist, da der Client keine Performance beansprucht, wenn die Logic Net Eye Software nicht gestartet ist.


Schnellstart

Für die ganz Ungeduldigen hier jetzt die Abkürzung durch die Anleitung:

1. Voraussetzungen

Da es sich um eine .Net-Anwendung handelt, muss das .Net-Framework 1.1 installiert sein. Weitere Informationen zu den einzelnen Voraussetzungen finden Sie auf der Seite Installation.

2. Installation

Die Logic Net Eye Server Software muss überhaupt nicht installiert werden - einfach die LogicNetEye.exe Datei irgendwo hin kopieren, starten und loslegen. Mehr Informationen finden Sie unter Installation.

3. Hinzufügen von Computern

Die Remote-Installation von Clients funktioniert über Netzwerk auf Windows NT, Windows 2000 & 2000 Server, Windows XP Professional und Windows 2003 Server Clients. Dazu kann die Schaltfläche Computer hinzufügen [image] in der Symbolleiste verwendet werden und die Rechner im sich öffnenden Computer hinzufügen - Dialog ausgewählt werden:

Es können mehrere Computer gleichzeitig ausgewählt und hinzugefügt werden. Neben der Auswahl von Computer kann der Name eines Computers oder die IP auch direkt in das Textfeld Computer: eingegeben werden. Die Schaltfläche OK startet die Remote-Installation der Client-Software auf den ausgewählten Computern. Weitere Informationen und die unterstützten Client-Betriebssysteme finden Sie auch unter Computer hinzufügen.

4. Anzeige der Computer

Nach der erfolgreichen Installation der Client-Software auf den angegebenen Computern melden sich diese beim Logic Net Eye-Server und werden als Miniaturansicht dargestellt:

Die Miniaturansicht stellt folgende Informationen dar:

Der Desktop eines Computers kann als Fenster in Originalgröße durch einen Doppelklick auf die Miniaturansicht dargestellt werden. Weiter kann im Ansicht - Menü eingestellt werden, ob die Miniaturansichten nach dem Namen des Computers, dem aktuellen Benutzer oder der IP des Computers sortiert dargestellt werden. Hier lässt sich auch die Größe der Miniaturansicht einstellen. Eine detaillierte Beschreibung der Miniaturansichten finden Sie unter Anzeige von Computern und Informationen über die Vollbildansicht unter Fensteranzeige eines Computers

5. Aufzeichnung von Computern

Mit der Schaltfläche Aufzeichnen [image] kann der Desktop eines Computers als Video aufgezeichnet werden. Standardmäßig werden die Aufzeichnungen im Eigene Dateien - Ordner im Verzeichnis Net Eye gespeichert. Der Pfad kann jedoch auch in den Optionen angepasst werden. Ausführliche Informationen zur Aufzeichnung finden Sie auf der Seite Aufzeichnen von Computern .

6. Entfernen von Computern

Sollte die Client-Software von einem Computer entfernt werden, so kann dies über die Schaltfläche Computer entfernen [image] geschehen. Dadurch wird die Client-Software rückstandsfrei von allen ausgewählten Computern entfernt. Mehr Informationen finden Sie unter Computer entfernen.

Weitere Informationen zu den Möglichkeiten von Logic Net Eye finden sie unter Verfahren. Im Bereich Optionen finden Sie Informationen zur Parametrisierung von Logic Net Eye.


Lizenz

Das Programm Logic Net Eye ist Eigentum des Autors LogicLink, Marcus Müller. Durch das Herunterladen und Installieren stimmen Sie den folgenden Lizenzbedingungen zu:

  1. Das Programm ist Freeware und darf solange Sie möchten verwendet werden.
  2. Sie dürfen einzelne, private Kopien der Software uneingeschränkt weitergeben, solange Sie die Dateien und die beigefügte Lizenz nicht verändern.
  3. Sie können Logic Net Eye auf einer Buch- oder Zeitschriften-CD veröffentlichen, wenn Sie uns eine kurze Nachricht über die Veröffentlichung an info@logiclink.de mailen.
  4. Für alle anderen Veröffentlichungen, wie z.B. die Bereitstellung der Software über Internet oder einen Spiegelserver, ist eine Erlaubnis des Autors notwendig.
  5. Das Programm bleibt auch bei der Weitergabe an Dritte immer Eigentum des Autors.
  6. Das Reverse Engineering ist nicht erlaubt. Sollten Zweifel an der Funktionsweise des Codes bestehen, so sind wir gerne bereit einer vertrauenswürdigen Institution, wie z.B. einer Universität, für eine begrenzte Zeit Einsicht in den Code zu erlauben.
  7. Der kostenlose Gebrauch beschränkt sich auf die gesamte Anwendung. Der alleinige Gebrauch einzelner Teile dieser Software, wie z.B. der Client-Software, ist nicht gestattet
  8. Die Software wurde mit größter Sorgfalt entwickelt. Trotzdem erfolgt die Benutzung des Programms auf eigene Gefahr. Daher schließen wir jegliche Haftung für Schäden, die direkt oder indirekt aus der Benutzung dieser Software entstehen, aus, soweit diese nicht auf Vorsatz oder grober Fahrlässigkeit unsererseits beruhen. Trotz aller Anstrengungen können wir Ihnen leider nicht garantieren, dass das Programm völlig frei von Fehlern ist, ohne Unterbrechung arbeitet und Ihren Ansprüchen gerecht wird. Das Programm wird geliefert "wie es ist" und die Verwendung erfolgt auf eigene Gefahr.


Spenden

Diese Software ist ein Zwischenergebnis eines unserer Forschungsprojekte. Das Ziel unseres Net Eye Projektes ist die technologische Machbarkeit einer massiv parallelen Übertragung von graphischen Daten in Netzwerken zu prüfen.

Nach unserer Überzeugung sollten Forschungsergebnisse für jedermann frei zugänglich sein... und was könnte besser sein, als eine Software, die diese Ergebnisse in der Form einer Freeware demonstriert. Daher stellt die Logic Net Eye Software sozusagen ein Zwischenergebnis unseres Forschungsprojektes dar.

Da es sich bei dem Projekt um pure Grundlagenforschung ohne kommerziellen Hintergrund handelt, sind wir auf Ihre tatkräftige Mithilfe bei der Weiterentwicklung des Projektes angewiesen. Aus diesem Grund bitten wir Sie, falls Sie unser Projekt und seine Ergebnisse interessant finden und uns bei der Weiterentwicklung helfen möchten, um eine Spende. Wenn Sie an einer Spende interessiert sind, schicken Sie uns einfach eine E-Mail an info@logiclink.de, Stichwort: Logic Net Eye.


Installation

1. Voraussetzungen

Logic Net Eye ist eine .Net basierte Entwicklung, die eine C++ Client-Software verwendet. Darüber hinaus benutzt das Programm das Windows Service API für die Remote-Installation der Client-Software auf Computern, deren Desktop Sie anzeigen wollen. Daraus ergeben sich folgende Systeme, auf denen Sie Logic Net Eye verwenden können:

Betriebssystem | Logic Net Eye Server | Net Eye Client-Software | Remote-Installation*
Microsoft Windows 95 | Nein | Ja | Nein
Microsoft Windows 98, 98SE | Ja | Ja | Nein
Microsoft Windows Me | Ja | Ja | Nein
Microsoft Windows NT 4 | Ja | Ja | Ja**
Microsoft Windows 2000 Professional & Server | Ja | Ja | Ja
Microsoft Windows XP Professional | Ja | Ja | Ja
Microsoft Windows XP Professional SP2 | Ja | Ja | Ja***
Microsoft Windows XP Home | Ja | Ja | Nein
Microsoft Windows 2003 Server | Ja | Ja | Ja

*Die Remote-Installation setzt Administrator-Rechte des Benutzers auf dem Client voraus.

**Administrative Admin$-Freigabe erforderlich, da NT einen Dienst nicht über einen UNC-Pfad starten kann.

*** Für die Remote-Installation muss der Port TCP 445 oder der komplette Datei- und Druckerfreigabe Dienst als Ausnahme in der Firewall des Clients eingerichtet sein.

Da es sich um eine .Net-Anwendung handelt, muss das .Net-Framework 1.1 auf dem Logic Net Eye Server installiert sein. Sie können das Framework unter http://www.microsoft.com/downloads als Microsoft® .NET Framework Version 1.1 Redistributable Package herunterladen. Auf den Clients ist keine zusätzliche Softwarekomponente außer der Logic Net Eye Client-Software notwendig.

Für die Aufzeichnung von Desktops werden Video-Codecs verwendet, die Sie ggf. installieren sollten. So kann der DivX-Codec durch die Installation des aktuellen DivX-Players installiert werden und der Microsoft MPEG-4 Video Codec V2 bekommen Sie über die Installation des aktuellen Windows Media Players.

Der Speicherbedarf der Logic Net Eye Anwendung auf der Festplatten ist eher moderat mit ca. 1MB, allerdings wird je nach Codec einiges an Speicherplatz für die Aufzeichnung von Videos benötigt. Für den Prozessor und Hauptspeicher gilt natürlich wie immer: Größer, schneller, breiter und zuviel ist nicht genug ;-) ! Aber ansonsten reicht ein Pentium II mit 400 und 128MB Speicher für die Anzeige aus, nur bei der gleichzeitigen Aufzeichnung von Videos wird viel Performance benötigt. Falls Sie die zufälliger Weise irgendwo verlegt haben sollten, kann der Performance-Hunger auch drastisch durch die Verwendung von Bitmap-Sequenzen statt eines Videoformates reduziert werden.

Andere Voraussetzungen, wie Monitor, Maus, Keyboard, Kaffee, wache Augen und ein neugieriger Verstand entsprechen den üblichen Anforderungen an Computerbesitzer. Ach ja, bevor ich das vergesse: ein Netzwerk und noch ein paar andere Rechner wären natürlich schon schön, denn sonst könnte man Logic Net Eye zwar als Screenshot-Tool für den eigenen Desktop missbrauchen, aber das geht auch einfacher ! Die Netzwerkverbindung sollte möglichst über TCP/IP hergestellt werden, damit keine Verständigungsprobleme zwischen der Logic Net Eye Server-Software und den Clients auftreten.

2. Installation

Logic Net Eye muss überhaupt nicht installiert werden - einfach die LogicNetEye.exe Datei irgendwo hin kopieren, starten und loslegen. Wenn's jedoch etwas ordentlicher werden soll, so kann LogicNetEye.exe auch in einen Ordner im Programme-Verzeichnis kopiert werden, wie z.B. "Programme\Logic Net Eye" und eine Verknüpfung im Startmenü erzeugt werden. Alternativ reicht auch der Download der Setup-Variante, der einem diese manuelle Arbeit abnimmt...

Die Installation der Client-Software kann remote erfolgen und wird ausgiebig im Kapitel "Hinzufügen von Computern" beschrieben.

3. Konfiguration

Die Anwendung speichert ihre komplette Konfiguration in einer XML-Datei namens LogicNetEye.config, die sich entweder im gleichen Verzeichnis wie die Exe-Datei, im Verzeichnis All Users\Anwendungsdaten\LogicLink oder im Verzeichnis %Benutzername%\Anwendungsdaten\LogicLink befinden kann. An den Stellen wird in dieser Reihenfolge gesucht, so dass sich mehrere Konfigurationen der Anwendung einfach durch eine Kopie der Konfigurationsdatei und der Exe herstellen lassen. Standardmäßig wird der Pfad %Benutzername%\Anwendungsdaten\LogicLink verwendet.

4. Speicherorte

Neben der Konfigurationsdatei speichert Logic Net Eye Desktop-Aufzeichnungen als Videos standardmäßig im Ordner "Eigene Dateien\Net Eye". Dieser Pfad lässt sich auch in den Optionen auf ein anderes Verzeichnis umbiegen - im übrigen eine gute Idee für wandernde Profile im Netzwerk, da sonst im schlimmsten Fall gigabyteweise Videodaten mit dem Profil hin- und herwandern.

5. Deinstallation

Falls Sie das Programm über Setup.exe oder die Microsoft Installer MSI-Datei installiert haben, können Sie das Programm am einfachsten über die Systemsteuerung unter dem Punkt Software deinstallieren. Anderenfalls reicht ein einfaches Löschen der Dateien. Falls Sie jetzt die Reihenfolge vertauscht haben, werden Sie wahrscheinlich mit der Auto-Reparatur des Microsoft Windows Installers konfrontiert und sollten die erste Variante nochmals probieren...


Start der Anwendung

In den meisten Fällen reicht ein Doppelklick auf die LogicNetEye.exe Datei oder die Auswahl von Logic Net Eye im Startmenü für einen Programmstart aus. Falls Sie jetzt mit irgendwelchen Fehlermeldungen konfrontiert werden, prüfen Sie bitte die unter Installation genannten Voraussetzungen. Falls es immer noch nicht funktioniert, schicken Sie uns einfach eine E-Mail mit Ihrer Systemkonfiguration und dem aufgetretenen Fehler. Spätestens, wenn wir Ihre E-Mail beantwortet haben, sollten Sie das folgende Hauptfenster von Logic Net Eye sehen:

Ansonsten gibt es keine Kommandozeilenparameter, versteckten Nagscreens, undurchsichtigen Registry-Einträge, usw. ..., oh, bevor ich's vergesse: Wenn Sie eine Webcam angeschlossen haben, bitte jetzt lächeln... ;-).


Computer hinzufügen

Um eine Verbindung mit einem anderen Computer zu bekommen und sich dessen Desktop anzeigen zu lassen, muss auf dem jeweiligen Rechner eine Client-Software, der Net Eye-Dienst, installiert werden. Damit Sie nicht ständig hin- und herlaufen müssen verwendet Logic Net Eye ein Remote-Installationsverfahren für diesen Dienst.

&

Das Remote-Installationsverfahren benutzt die offiziellen Mechanismen zur Remote-Installation von Diensten, wie sie Microsoft für die Windows NT basierten Betriebssysteme vorsieht. Daher greifen auch alle Sicherheitsmechanismen, die Windows für einen Netzwerkzugriff vorsieht. So muss der Benutzer, der mit Logic Net Eye den Client-Dienst auf einem Computer installieren will, das Recht zur Installation eines Dienstes auf diesem Rechner haben. Dies gilt typischer Weise für ein Mitglied der Administratoren - Gruppe auf dem Client. Der eigentliche Client-Dienst besteht aus der Exe-Datei NetEye.exe, die auf den Client-Computer kopiert wird.

Darüber hinaus muss natürlich auch der TCP Port 445 auf dem Client erreichbar sein, damit die Dienst-Verwaltung via Remote Procedure Call (RPC) überhaupt mittels Netzwerk erreichbar ist. Dies ist z.B. in der Standardkonfiguration der Windows XP Service Pack 2 Firewall nicht mehr der Fall. Ein abhanden gekommener TCP Port 445 auf dem Client äußert sich meist durch die Fehlermeldung "Der RPC-Server ist nicht verfügbar".

Also, nicht verzagen, wenn's mal mit der Remote-Installation nicht klappt, sondern schnurstracks in die nächste Bibliothek laufen, die neuesten 20 Kilogramm Literatur über TCP/IP Netzwerke, Routing, Firewalls und Sicherheitseinstellungen unter Windows ausleihen oder einfach in der Betriebssystem-Tabelle auf der Seite Installation nachschlagen.

Zu dem Thema "Wie umgehe ich denn all diese Einschränkungen ?" komme ich weiter unten bei der manuellen Installation.

1. Remote-Installation

Wenn diese Vorbedingungen erfüllt sind, kann die Client-Software auf einem weiteren Computer über den Menüpunkt Computer/Hinzufügen oder über die Schaltfläche Computer hinzufügen [image] in der Symbolleiste installiert werden. Zusätzliche Computer können im Computer hinzufügen - Dialog ausgewählt werden:

Der Dialog zeigt alle im Netzwerk vorhandenen Rechner nebst IP-Adresse und Betriebssystem an. Er verwendet dazu den gleichen Mechanismus, wie die Netzwerkumgebung des Windows-Explorers - mit den gleichen Nebeneffekten, wie eine fürchterlich lange Dauer für die Suche, Rechner, die manchmal angezeigt und dann wieder nicht angezeigt werden und Betriebssysteminformationen, die mal nur Windows 9x-Systeme von NT-Systemen unterscheiden und mal die präzise Versionsnummer bis zum Service Pack herunter ausgeben. Die netzwerkweite Suche können Sie im übrigen auch durch die F5 - Taste händisch wiederholen und so die Anzeige aktualisieren.

Aber auch in diesem Fall gilt: Bloß nicht entmutigen lassen ! Der Dialog ist so konstruiert, dass die Suche nach weiteren Computern im Hintergrund abläuft, während Sie schon mal Ihre Lieblinge per Hand in das Textfeld Computer eingeben können. Sie können hier mehrere, durch Komma getrennte Computernamen und IP-Adressen angeben. Mit der Schaltfläche OK bestätigen sie die Auswahl im Feld Computer und der Installationsprozess wird auf den angegebenen Computern gestartet.

Wenn Sie unter ihrem aktuellen Benutzernamen nicht über Andministrator-Rechte auf den hinzuzufügenden Computern verfügen, können Sie über die Schaltfläche Benutzer einen anderen Benutzernamen angeben, mit dem der Client-Dienst auf den ausgewählten Rechnern installiert werden soll. Voraussetzung für diese Funktion ist, dass die Logic Net Eye Software auf einem Windows XP oder neuerem System ausgeführt wird.

Dieser Installationsprozess kann bei mehreren Rechnern etwas länger Dauern, da die Dienste-Verwaltung ein etwas zähes Reaktionsverhalten zeigt. Nach der erfolgreichen Installation wird der Client-Dienst auf dem ausgewählten Rechner gestartet und meldet sich mit einer Miniaturansicht im Hauptfenster der Anwendung. Alternativ wird Ihnen eine Fehlermeldung angezeigt, die Ihnen eine Idee davon gibt, wieso die Client-Software gerade jetzt nicht auf dem Computer installiert oder gestartet werden kann.

2. Die Client-Software

Die Client-Software besteht aus einer NetEye.exe Datei, die alle notwendigen Komponenten für die Übertragung des Desktops beinhaltet. Weiter ist in der Datei der Name und der Port des Logic Net Eye Servers gespeichert, damit der Client auch seinen Server wiederfindet. D.h. jedoch, dass ein Client sich immer nur mit einem Server unterhalten kann. Falls Sie jetzt also den Client von einem anderen Rechner aus installieren, verliert der Client die Verbindung zum ersten Logic Net Eye Server ! Um diesen Effekt zu vermeiden, können sie auch den DNS-Namen für eine dynamische IP in den Optionen der Logic Net Eye - Anwendung angeben und so die Clients auf verschiedene Logic Net Eye Server umleiten.

Die Client-Software selber unterstützt folgende Kommandozeilenparameter:

Parameter | Beschreibung
-i | Installiert den Client als Windows-Dienst. Dabei wird der aktuelle Pfad der NetEye.exe - Datei in der Registry hinterlegt - also die Exe vorher an die richtige Stelle kopieren ! Die Installation funktioniert mit diesem Parameter sowohl unter Windows NT - 2003 als auch unter Windows 95/98/Me.
-u | Deinstalliert den Client als Windows-Dienst. Die Deinstallation funktioniert mit diesem Parameter sowohl unter Windows NT - 2003 als auch unter Windows 95/98/Me.
-r | Führt den Client aus, ohne ihn zu installieren. Dies ist für einen Test recht interessant, da der Dienst nicht ständig installiert und wieder deinstalliert werden muss.

Unter Windows NT, 2000, XP und 2003 erscheint der Client in der Dienste-Verwaltung als Net Eye - Dienst und kann dort gestartet oder beendet werden. Hierbei kann es zu einer Deadlock-Situation kommen, wenn Sie den Starttyp des Dienstes in der Dienste-Verwaltung auf dem Client auf deaktiviert ändern. In diesem Fall kann der Dienst zur Zeit weder neu gestartet, noch vom Logic Net Eye Server deinstalliert werden.

Bei den Betriebssystemen Windows 95, 98, 98SE und Me trägt sich der Dienst in der Registry unter HKLM\Software\Microsoft\Windows\CurrentVersion\RunServices ein und registriert sich gegenüber dem Betriebssystem als Dienst. Das hat zur Folge, dass der NetEye.exe-Prozess nicht im Windows-Taskmanager angezeigt wird. Er wird jedoch in anderen Taskmanagern, wie z.B. Mark Russinovich's Process Explorer mit aufgelistet.

3. Manuelle Client-Installation

Falls Sie einen Computer mit Microsoft Windows 9x, Me oder XP Home hinzufügen wollen, kommen Sie um eine Turnschuh-Installation nicht herum. Als erstes müssen Sie die Client-Software mit dem Menüpunkt Extras/Exportiere Client... erzeugen. In diesem Schritt wird die Exe-Datei mit der entsprechenden Server-Adresse und dem Port irgendwo im Dateisystem gespeichert. Wo können Sie angeben und hier empfiehlt sich ein transportables Medium, wie z.B. die gute, alte Diskette...

Als nächstes müssen Sie die Datei auf den Client-Computer kopieren. Hier bietet sich das System oder System32 - Verzeichnis des Windows-Ordners an. Zum Schluss installieren Sie die Client-Software mit dem Kommandozeilenaufruf NetEye.exe -i.

Den kompletten Vorgang können Sie natürlich auch mit einem anderen Software-Verteilungsprogramm oder über ein Logon-Skript durchführen und so doch noch Schuhsohlen sparen...


Anzeige von Computern

Computer, die sich an beim Logic Net Eye Server gemeldet haben, werden als Miniaturansicht dargestellt. Im Menü Ansicht kann die Darstellung dieser Miniaturansichten gesteuert werden. So können drei verschiedene Größen der Miniaturansichten über die Menüpunkte Klein, Normal und Groß eingestellt werden. Unter dem Menüpunkt Anordnen nach kann die Sortierung der einzelnen Miniaturansichten geändert werden. Neben der Sortierungsreihenfolge ändert sich hierbei auch die Bezeichnung der einzelnen Miniaturansicht und es wird immer das Feld angezeigt, nach dem sortiert wurde.

Die Miniaturansicht eines Computers stellt den Desktop des Rechners, sowie zusätzliche Informationen über den Computer dar:

Sie können eine oder mehrere Miniaturansichten mit der Maus auswählen. Bei gedrückter Umschalttaste markieren Sie einen zusammenhängenden Bereich von Miniaturansichten markieren, während Sie bei gedrückter Steuerungstaste nicht nebeneinander liegende Miniaturansichten auswählen können.

Der Status wird über ein Symbol in der linken, unteren Ecke der Miniaturansicht angezeigt und kann folgende Werte haben:

Symbol | Status | Beschreibung
 | Unbekannt | Der Computer wurde zwar vom Logic Net Eye Server hinzugefügt, hat aber keine Verbindung mehr zum Server. Dieser Status wird ebenfalls durch das große [image] Symbol über der Desktop-Aufnahme angezeigt und tritt z.B. bei deaktivierte Client-Software auf dem jeweiligen Computer oder bei Verbindungsschwierigkeiten auf.
 | Aktiv | Der Computer hat eine Verbindung zum Logic Net Eye Server und überträgt seinen Desktop im eingestellten Zeitintervall.
 | Angehalten | Es besteht eine Verbindung zwischen Computer und Logic Net Eye Server, die Datenübertragung wurde jedoch angehalten.Sie können die Übertragung jederzeit durch den Fortsetzen - Befehl wieder starten.
 | Aktiv, Aufnahme | Der Computer hat eine Verbindung zum Logic Net Eye Server und überträgt seinen Desktop im eingestellten Zeitintervall. Darüber hinaus wird die Übertragung als Video oder Bitmap-Sequenz aufgezeichnet. Dies könnte z.B. auch ihren unter Vollast arbeitenden Prozessor erklären...
 | Beendet | Sie haben die Client-Software auf dem Computer beendet. Dadurch besteht keine Verbindung mehr zwischen Computer und Logic Net Eye Server. Da sie den Abbruch der Verbindung selbst provoziert haben, nimmt die Software an, Sie wussten was sie taten und das große [image] Symbol über der Desktop-Aufnahme wird nicht angezeigt. Ansonsten entspricht der Status dem vorher beschriebenen Unbekannt - Status.

Neben dem Status wird je nach Sortierung der Name des Computers, des aktuellen Benutzers oder die IP des Computers angezeigt. Alle Daten des betreffenden Computers werden als Quickinfo angezeigt, wenn Sie die Maus über einer Miniaturansicht ein wenig verweilen lassen:

In der Fußzeile ganz rechts wird der Zeitpunkt der letzen Aufnahme des Desktops angezeigt. Die Zeit wurde auf dem Client ermittelt und wird mit dem Desktop übertragen. Falls Sie hier abstruse Zeitangaben im laufenden Betrieb sehen, sollten Sie möglicherweise die Uhr auf dem entsprechenden Computer neu einstellen...


Fensteranzeige eines Computers

Fensteransicht eines Computers

Durch einen Doppelklick auf die Miniaturansicht eines Computers öffnen Sie dessen Desktop in einem eigenen Fenster. Alternativ kann die Fensteransicht auch mit der Eingabe-Taste für alle ausgewählten Computer geöffnet werden. Der Desktop des Computers wird erst bei der nächsten Rückmeldung des Computers in voller Auflösung übertragen. Daher wundern sie sich nicht über ein sehr grobes Bild in den ersten Sekunden...

Die Fensteransicht bietet im Ansicht - Menü die Möglichkeit den Desktop zu skalieren oder ihn in voller Größe anzuzeigen. Die unskalierte Anzeige erhöht deutlich die Lesbarkeit von Schriften auf dem übertragenen Bild, zeigt jedoch je nach Auflösung nicht den kompletten Desktop des Computers an. Für alle, die sich den 21"-Monitor noch nicht leisten können, haben wir für diesen Fall Scrolleisten mit eingebaut.

Alternativ kann die Fensteransicht auch im Vollbild-Modus mit dem Menüpunkt Anzeige/Vollbild ohne Fensterrand und Menü angezeigt werden. Dadurch nimmt sie den kompletten Bildschirm des Logic Net Eye Servers ein. Falls Sie diesen Befehl ausgeführt haben, werden Sie sich wahrscheinlich fragen, wie sie den Vollbild-Modus wieder beenden, da alle Menüs und Ihr Desktop wahrscheinlich verschwunden sind. In diesem Fall hilft die Taste F11 weiter, die zwischen Fenster und Vollbild hin- und herschaltet.


Computer beenden und starten

Der Befehl Beenden stoppt die Client-Software vollständig auf den ausgewählten Computern. Sie sollten diese Funktion mit Vorsicht verwenden, da für das erneute Starten der Client-Software mit dem Befehl Starten ein Zugriff auf die Dienste-Verwaltung des Computers notwendig ist. Dieses funktioniert jedoch nur bei Windows NT, 2000, XP und 2003 Computern und nicht auf Windows 95, 98 und Me Rechnern.

In den Fällen, in denen das erneute Starten der Client-Software nicht möglich ist, bleibt Ihnen nur das Warten auf den nächsten Neustart, bei dem der Client-Dienst automatisch neu gestartet wird und versucht den Logic Net Eye Server zu kontaktieren. Sie können die beiden Befehle mit den Menüpunkten Computer/Beenden bzw. Computer/Starten ausführen.


Computer anhalten und fortsetzen

Die Client-Software auf einem Computer kann über den Befehl Anhalten angehalten werden. Dadurch stoppt der Client seine Datenübertragung, läuft jedoch weiterhin auf dem Client-Computer und meldet sich in regelmäßigen Intervallen beim Logic Net Eye Server. Die Häufigkeit, mit der sich der Client beim Server meldet, kann im übrigen in den Optionen eingestellt werden.

, &

Mit dem Befehl Fortsetzen setzt ein angehaltener Client seine Datenübertragung fort. Dieser Mechanismus kann dazu genutzt werden, dem Client-Computer maximale Performance und Netzwerkbandbreite zur Verfügung zu stellen. Die beiden Befehle können entweder mit den Schaltflächen Anhalten [image] und Fortsetzen [image] oder mit den Menüpunkten Computer/Anhalten bzw. Computer/Fortsetzen ausgeführt werden. Die Befehle werden an die in der Miniaturansicht ausgewählten Computer gesendet.


Aufzeichnen von Computern

Sie können die Übertragung des Desktops eines Computers aufzeichnen. Dazu stehen Ihnen die Menübefehle Aufzeichnung/Starten und Aufzeichnung/Beenden im Hauptmenü oder die Schaltfläche Aufzeichnen [image] in der Symbolleiste zur Verfügung. Die Befehle werden für alle ausgewählten Miniaturansichten ausgeführt.

&

Die Aufzeichnungen werden im Ordner Eigene Dateien\Net Eye gespeichert. Der Speicherort lässt sich in den Optionen ändern. Wenn ein Video-Codec als Kompressor eingestellt ist, wird die Datei in diesem Ordner unter dem folgenden Namen gespeichert:

JJMMTT.SSMM.Computer.IP.avi

Bei der Aufzeichnung von Bitmap-Sequenzenzen werden Einzelbilder in einem Ordner, der den Namen des Computers trägt, im Verzeichnis Eigene Dateien\Net Eye gespeichert. Hierbei wird das folgende Format für Ordner und Dateinamen verwendet:

Computer/JJMMTT.SSMMss.mmm.png

Zeichen | Beschreibung
J | Jahr
M | Monat
T | Tag
S | Stunde
M | Minuten
s | Sekunden
m | Millisekunden
Computer | Name des Computers
IP | IP-Adresse in Punkt-Notation

Es können folgende Codecs zur Aufzeichnung verwendet werden:

Codec | Beschreibung
Radius Cinepak | Wird als Standard verwendet und sollte auf den meisten Rechnern verfügbar sein. Die Kompression ist nur mäßig, d.h. es entstehen große Dateien.
DivX Codec | Sehr gute Kompression bei gleichzeitig hoher Prozessorlast. Es entstehen kleine Video-Dateien, jedoch sollte dieser Codec nicht für die parallele Aufzeichnung von vielen Computern verwendet werden, es sei denn jemand borgt sich gerade mal ein Xeon 8-fach System ;-)
Microsoft MPEG-4 Video Codec V2 | Ebenfalls sehr gute Kompression bei gleichzeitig hoher Prozessorlast. Wie bei DivX Es entstehen kleine Video-Dateien, jedoch sollte auch dieser Codec nicht für die parallele Aufzeichnung von vielen Computern verwendet werden.
Intel Video 5.0 | Mittelmäßige Kompression und Prozessorlast.
Unkomprimiert | Riesige Video-Dateien bei mäßiger Prozessorlast.
Bitmap-Sequenz | Es werden nur PNG-Bilddateien geschrieben. Dieses Verfahren produziert zwar keine Videos, stellt aber dafür die definitiv geringsten Ansprüche an Prozessor und Speicherplatz. Das Verfahren sollte zur Zeit für lang laufende Aufzeichnungen oder bei vielen gleichzeitigen Aufzeichnungen verwendet werden.

Bei einer Aufzeichnung wird neben dem Desktop eine Fußzeile mit dem Zeitpunkt der Aufnahme, dem Computernamen und angemeldeten Benutzer angefügt. Bei der Aufzeichnung eines Videos versucht der Logic Net Eye Server ein Echtzeitvideo zu erstellen. D.h., je nach Aktualisierungsintervall werden Zwischenbilder in das Video eingefügt, die durch eine sich nicht ändernde Zeitangabe in der Fußzeile zu erkennen sind.

Es können folgende zusätzlichen Aufnahme-Einstellungen in den Optionen vorgenommen werden:

Einstellung | Beschreibung
Größe | Die Aufzeichnung kann skaliert werden. Hierbei reduziert sich die Prozessorlast und der benötigte Speicherplatz für die Aufzeichnung. Allerdings sind Schriften auf dem aufgezeichneten Desktop bei einer Verkleinerung nur noch schwer bis überhaupt nicht mehr zu entziffern.
Qualität | Diese Einstellung wirkt sich je nach eingestelltem Kompressor auf die Qualität des aufgezeichneten Videos aus.


Computer aktualisieren

Bei der Übertragung des Desktops werden nur geänderte Bereiche neu gesendet. Sollte es zu Darstellungsfehlern kommen, kann für die ausgewählten Computer mit der Schaltfläche Aktualisieren [image] oder mit dem Menübefehl Computer/Aktualisieren der komplette Desktop neu angefordert werden.

&


Computer entfernen

Die Client-Software auf einem Computer kann mit dem Menüpunkt Computer/Entfernen, über die Schaltfläche Computer entfernen [image] in der Symbolleiste oder die Enf - Taste deinstalliert werden. Es werden alle Computer, deren Miniaturansicht ausgewählt wurde, entfernt.
Beim Entfernen eines Computers wird ein Kommando zum Client geschickt, das für die Deinstallation des Dienstes und das Löschen der NetEye.exe sorgt.

&

Daher ist auch eine Verbindung zum Client notwendig, um den Befehl auszuführen. Falls diese nicht existiert, wird die Miniaturansicht zwar entfernt, erscheint jedoch wieder, wenn sich der Client das nächste Mal beim Server meldet. Tote Clients leben also länger... Dieser Deinstallationsmechanismus ist unabhängig von der Windows-Version auf der die Client-Software läuft.

Sie sollten jedoch überlegen, ob Sie einen Client überhaupt entfernen sollten, denn die Client-Software frisst nur geringe Resourcen, wenn der Logic Net Eye - Server geschlossen ist und keine keine Verbindung vom Client aus hergestellt werden kann.


Optionen für die Aufzeichnung

Sie können die Optionen für die Aufzeichnung unter dem Menüpunkt Extras/Optionen oder über die Schaltfläche Optionen [image] in der Symbolleiste aufrufen. Es lassen sich hier folgende Eigenschaften übergreifend für alle Aufzeichnungen einstellen:

&

Einstellung | Wert | Beschreibung
Größe | 5% - 100% | Größe der Aufzeichnung in Bezug zur Desktop-Größe des Computers. Bei geringeren Größen reduziert sich die Prozessorlast und der benötigte Speicherplatz für die Aufzeichnung.
Kompressor | Radius Cinepak | Wird als Standard verwendet und sollte auf den meisten Rechnern verfügbar sein. Die Kompression ist nur mäßig, d.h. es entstehen große Dateien.
 | DivX Codec | Sehr gute Kompression bei gleichzeitig hoher Prozessorlast. Es entstehen kleine Video-Dateien, jedoch sollte dieser Codec nicht für die parallele Aufzeichnung von vielen Computern verwendet werden, es sei denn jemand borgt sich gerade mal ein Xeon 8-fach System ;-)
 | Microsoft MPEG-4 Video Codec V2 | Ebenfalls sehr gute Kompression bei gleichzeitig hoher Prozessorlast. Wie bei DivX Es entstehen kleine Video-Dateien, jedoch sollte auch dieser Codec nicht für die parallele Aufzeichnung von vielen Computern verwendet werden.
 | Intel Video 5.0 | Mittelmäßige Kompression und Prozessorlast.
 | Unkomprimiert | Riesige Video-Dateien bei mäßiger Prozessorlast.
 | Bitmap-Sequenz | Es werden nur PNG-Bilddateien geschrieben. Dieses Verfahren produziert zwar keine Videos, stellt aber dafür die definitiv geringsten Ansprüche an Prozessor und Speicherplatz. Das Verfahren sollte zur Zeit für lang laufende Aufzeichnungen oder bei vielen gleichzeitigen Aufzeichnungen verwendet werden.
Pfad | Eigene Dateien\Net Eye | Hier werden standardmäßig alle Aufzeichnungen gespeichert. Der Pfad kann auf ein beliebiges Verzeichnis umgebogen werden. Bei wandernden Benutzerprofilen im Netzwerk sollte dies in jedem Fall geschehen, da sonst u. U. erhebliche Datenmengen mit dem Profil hin- und her kopiert werden müssen.
Qualität | Standard, 0% - 100% | Gibt die Qualität des aufgezeichneten Videos an. Die Einstellung wird von dem ausgewählten Kompressor ausgewertet.


Optionen für den Client

Sie können die Optionen für den Client unter dem Menüpunkt Extras/Optionen oder über die Schaltfläche Optionen [image] in der Symbolleiste aufrufen. Die Einstellungen gelten übergreifend für alle Computer, die Sie hinzugefügt haben. Es lassen sich hier folgende Eigenschaften einstellen:

&

Einstellung | Wert | Beschreibung
Aktualisierungsinterval | 0,1 - 600 Sekunden | Gibt das Intervall an, in dem der Client seine Daten senden soll. Bei kurzen Intervallen kann es bei leistungsschwachen Computern zu einer Beeinträchtigung der Rechnerleistung kommen, da sehr viele Daten innerhalb einer kurzen Zeitspanne gesendet werden müssen. Je nach Einsatzgebiet sollten Sie daher ein Intervall von 1 Sekunde für eine Online-Beobachtung verwenden, während für die Überwachung von vielen Rechnern ein Intervall von 3 - 5 Sekunden ausreichend ist. Die anderen Werte sind eher zum Herumspielen gedacht...
Farbauflösung | Standard, Monochrom, 16 Farben, 16 Graustufen, 256 Farben, 256 Graustufen, 16 Bit, 24 Bit, 32 Bit | Die Farbauflösung bestimmt die Farbtiefe, mit der der Desktop eines Computers übertragen wird. Durch eine Reduktion der Farbtiefe kann die zu verarbeitende Datenmenge reduziert werden und so die Prozessor- und Netzwerkbelastung für den Client reduziert werden. Falls die Farbqualität keine Rolle spielt und die Lesbarkeit des Desktops im Vordergrund steht, liefert eine Übertragung mit 256 Farben die besten Ergebnisse. Der Wert Standard übernimmt die auf dem Client-Computer eingestellte Farbauflösung und sollte verwendet werden, wenn die Darstellung identisch mit dem Client sein soll.


Optionen für den Server

Sie können die Optionen für den Logic Net Eye Server unter dem Menüpunkt Extras/Optionen oder über die Schaltfläche Optionen [image] in der Symbolleiste aufrufen. Es lassen sich folgende Eigenschaften einstellen:

&

Einstellung | Wert | Beschreibung
Name | Computername | Diesen Namen verwendet die Client-Software, um Kontakt mit dem Logic Net Eye Server aufzunehmen. Hier wird als Standard der Name des Rechners vorgeschlagen, auf dem die Logic Net Eye Software gestartet wurde. Alternativ kann hier ein vollständiger DNS-Name oder eine IP angegeben werden. Dies lässt z.B. die Verwendung einer dynamischen IP zu, wie sie z.B. DynDNS bietet und bietet so die Möglichkeit, von mehreren Rechnern aus auf die gleichen Clients zuzugreifen. Der Name des Servers wird beim Hinzufügen von Computern fest in der Client-Software verankert. Daher sollten Sie bei einer Änderung des Namens die bisherigen Computer entfernen und neu hinzufügen, damit die Änderungen auch von allen Clients übernommen wird.
Port | z.B. 10001 | Port auf dem die Client-Software den Server kontaktiert. Hier sollte kein Port eingestellt werden, der einen Konflikt mit bestehenden Diensten auf dem Server hervorruft. So belegt z.B. ein Web Server standardmäßig den Port 80. Generell sollten Ports oberhalb von 1024 verwendet werden, damit keine Standardports verwendet werden.
Protokoll | Ja/Nein | Gibt an, ob die Kommunikation mit den Clients in einer Protokoll-Datei aufgezeichnet werden soll. Dies kann für die Fehleranalyse hilfreich sein.


Support

Bei Fragen, Fehlern, Anregungen, Wünschen und Kommentaren wenden Sie sich am einfachsten via E-Mail unter info@logiclink.de oder über das Kontakt-Formular auf unserer Website an uns. Wir freuen uns über jede Rückmeldung und werden versuchen, Ihre Fragen schnellstmöglich zu beantworten.